Keystrokes have no function

Development discussion forum for the App
Post Reply
hamilton5
Posts: 3
Joined: Fri Oct 21, 2016 2:40 am

Keystrokes have no function

Post by hamilton5 » Fri Oct 21, 2016 3:43 am

Hi, Firsty great app - well done.

I am running oscRFR on a new install on an iPad Mini. I believe I have the EOS settings set up as per the screenshots on your site. I am connecting to the main console (an RPU 3). I am connected to it successfully. I can see the cue list ticking over on the "remote" tab when the operator hits go.

I can change tabs from Remote, to Focus, to Direct Selects etc but these tabs are the only buttons that work. None of the other keystrokes go onto the command line. Sounds like some sort of comms issue but I can't see it.

Any help would be appreciated.

Thanks
D.

hamilton5
Posts: 3
Joined: Fri Oct 21, 2016 2:40 am

Re: Keystrokes have no function

Post by hamilton5 » Fri Oct 21, 2016 3:48 am

I should also mention that ETC's RFR software is working properly from the same device on the same wireless network.

Thanks

hamilton5
Posts: 3
Joined: Fri Oct 21, 2016 2:40 am

Re: Keystrokes have no function

Post by hamilton5 » Fri Oct 21, 2016 7:12 am

Stand down.... Problem solved,,,, I think,...

User avatar
Mothership
Site Admin
Posts: 51
Joined: Wed Aug 06, 2014 5:19 am

Re: Keystrokes have no function

Post by Mothership » Sat Oct 22, 2016 12:43 am

Hi there,

Hopefully it's worked out? If you need anything more just let us know.

mdebusk2
Posts: 1
Joined: Fri Nov 11, 2016 8:02 pm

Re: Keystrokes have no function

Post by mdebusk2 » Sat Nov 12, 2016 11:43 pm

Hi,

I purchased the app on Friday afternoon and followed all of the instruction in the ETC Connect page, but my keystrokes are not functioning. I can see what's happening on the board, but I can't control what's going on. I think it's the same problem listed here; however, after two hours of fighting with it, I was unable to find the solution.

Thanks!

User avatar
Mothership
Site Admin
Posts: 51
Joined: Wed Aug 06, 2014 5:19 am

Re: Keystrokes have no function

Post by Mothership » Sun Nov 13, 2016 6:58 pm

This is almost always to do with a setup option somewhere. It sounds like you are getting communication in only 1 direction.

Step 1 - Triple check the settings here : http://www.alienstagecraft.com/connecttoeos.html

Step 2 - take screen shots of Setup, Network setup in the EOS Shell + post your Router settings, IP addresses and all the stuff.

We have yet to have a situation where we didn't find the problem.

Best-

Druuka
Posts: 9
Joined: Fri Aug 08, 2014 7:29 pm

Re: Keystrokes have no function

Post by Druuka » Sun Nov 13, 2016 9:31 pm

I'm uploading a screenshot of the show control section of setup. I have been seeing that people forget to turn on the String RX because it doesn't say OSC. This would cause the buttons on the remote to not work.

Open Tab 99 in the console and turn on incoming OSC monitoring. This will give you more info on what is actually getting to the console.

Hope this helps,

Andrew
Attachments
oscRFR show control.jpg

Post Reply